Write a C++ program to print the given pattern.
Sample Input:
4
Sample Output:
1
2 3
4 5 6
7 8 9 10
Program Code:
#include <iostream>
using namespace std;
int main()
{
int i,j, k,n;
cout<<"Enter a number :";
cin>>n;
k=1;
for(int i = 1; i <=n; i++)
{
for(int j = 1; j<=i; j++)
{
if(i==j)
{
cout<<k;
}
else
{
cout<<k<<" ";
}
k++;
}
cout << endl;
}
return 0;
}
The program output is tested on www.jdoodle.com
Output:
Enter a number : 4
1
2 3
4 5 6
7 8 9 10
Thanks
Mukesh Rajput
Thanks
Mukesh Rajput
Post A Comment:
0 comments: