Write a C++ program to print the given pattern.
Sample Input: 5
Sample Output:
5
4 5
3 4 5
2 3 4 5
1 2 3 4 5


Program Code: 
#include <iostream>
using namespace std;
int main()
{
int i,j, k,n;
cout<<"Enter a number : ";
cin>>n;
k=n;
for(int i = n; i >=1; i--)
{
for(int j = k; j<=n; j++)
{
if(j==n)  
cout<<j;
else
cout<<j<<" ";
}
cout<<endl;
k--;
}
return 0;
}

The program output is tested on www.jdoodle.com
Output:
Enter a number : 5
5
4 5
3 4 5

2 3 4 5
1 2 3 4 5

Thanks
Mukesh Rajput
Mukesh Rajput

Mukesh Rajput

I am a Computer Engineer, a small amount of the programming tips as it’s my hobby, I love to travel and meet people so little about travel, a fashion lover and love to eat food, I am investing a good time to keep the body fit so little about fitness also..

Post A Comment:

0 comments: