Write a C++ program to print the given pattern.
Sample Input: 5
Sample Output:
1 1 1 1 1
2 2 2 2
3 3 3
4 4
5
Program Code:
#include <iostream>
using namespace std;
int main()
{
int i,j, n;
cout<<"Enter a number : ";
cin>>n;
for(int i = 1; i <=n; i++)
{
if(n==1)
{
cout<<i<<" ";
break;
}
else
{
for(int j = n; j >=i; --j)
{
if(j==i)
{
cout<<i;
}
else
{
cout << i <<" ";
}
}
}
cout << endl;
}
return 0;
}
The program output is tested on www.jdoodle.com
Output:
Enter a number : 5
1 1 1 1 1
2 2 2 2
3 3 3
4 4
5
Thanks
Mukesh Rajput
2 2 2 2
3 3 3
4 4
5
Thanks
Mukesh Rajput
Post A Comment:
0 comments: