Write a C++ program to print the given pattern.
Sample Input:  5
Sample Output:
5
4 4
3 3 3
2 2 2 2
1 1 1 1 1

Sample Input:  3
Sample Output:
2 2 
1 1 1 

Program Code:
#include <iostream>
using namespace std;
int main()
{
int i,j, k,n;
cout<<"Enter a number : ";
cin>>n;
k=n;
for(int i = 1; i <=n; i++)
{
for(int j = 1; j<=i; j++)
{
if(j==i)
{
cout<<k;
}
else
{
cout<<k<<" ";
}
}
k--;
 cout << endl;
}
return 0;
}
The program output is tested on www.jdoodle.com

Output 1:
Enter a number :5
5
4 4
3 3 3
2 2 2 2
1 1 1 1 1


Output 2:
Enter a number :3
2 2 
1 1 1 

Thanks
Mukesh Rajput
Mukesh Rajput

Mukesh Rajput

I am a Computer Engineer, a small amount of the programming tips as it’s my hobby, I love to travel and meet people so little about travel, a fashion lover and love to eat food, I am investing a good time to keep the body fit so little about fitness also..

Post A Comment:

0 comments: